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Supplement: Org Plus for Windows

version 2.0

This supplement presents detailed instructions for using Org Plus for
Windows version 2.0. It should be used in conjunction with the Org
Plus for Windows User’s Manual. All references made to Org Plus,
unless specifically stated otherwise, are made to Org Plus for
Windows version 2.0.

New features

The following are the new features available in this version:

Object Linking and Embedding (OLE) server support
Windows metafile (WMF) file format support

TIFF (tagged image file format) (TIF) support

PC Paintbrush® (PCX) file format support

Org Plus Exchange (OPX) file format support

Saving printer settings with your chart

Setting font style and size from a single command
Placing WMF, TIFF, and PCX pictures

The first five new features: OLE, WMF, TIFF, PCX and OPX
support are described in the “Using Org Plus with other applications”
section of this supplement.

The other features are described in the “Other features and hints”
section, also in this supplement.

Version 2.0 supplement 1



Differences from
version 1.0 installation

Org Plus for Windows
version 1.0 users

Installation

To install Org Plus, follow the installation instructions on page 7 of
the Org Plus for Windows User’s Manual. The installation
instructions are the same with the following exceptions:

Org Plus now requires 2 megabytes instead of 1.5 megabytes of free
disk space.

In addition to the files listed in “What’s on your disk,” page 10 of the
Org Plus for Windows User’s Manual, the following utility files are
also copied:

P3DISP.DLL
P3FILE.DLL
P3EDIT.DLL
P3CONV.DLL
P3DIB.DLL
P3COLOR.DLL
P3INFO.DLL

If you are a Windows 3.0 user, additional files may be required by
your system. Follow the instructions on the screen.

Org Plus for Windows version 2.0 can open Org Plus for Windows
version 1.0 charts but Org Plus for Windows version 1.0 cannot open
Org Plus for Windows version 2.0 charts.
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Opening Org Plus for
DOS files

Using Org Plus with other applications

This section replaces Appendix E, page 213, in the Org Plus for
Windows User’s Manual.

Org Plus for Windows can open charts from files in any of the
following formats:

m  Org Plus for DOS (versions 3.1 and above)
m Comma-delimited text
m  Tab-delimited text

Org Plus for Windows can save charts in any of the following
formats:

Org Plus for DOS (versions 3.1 and above)
Comma-delimited text

Tab-delimited text

Windows bitmap (BMP)

Windows metafile (WMF)

TIFF (tagged image file format) (TIF)

PC Paintbrush (PCX)

Org Plus for Windows also supports Object Linking and Embedding.
This Windows feature lets you create and edit a chart in Org Plus and
automatically transfer it to another Windows application such as a
word processor or desktop presentation program. See “Object
Linking and Embedding,” page 16, for more information.

Org Plus for Windows can open chart files created by Org Plus
version 3.1 and Org Plus Advanced version 4.0 and above.

Org Plus version 3.1, Org Plus Advanced version 4.0, 5.0, and 6.0
share the same chart file format. Org Plus Advanced version 6.01
and above use the Org Plus Exchange (OPX) chart file format. Org
Plus for DOS drawing (DWG) files cannot be opened.
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To open an Org Plus for DOS chart (Org Plus version 3.1 or Org
Plus Advanced version 4.0, 5.0, or 6.0), do the following:

1. Choose Open from the File menu.
The Open Chart dialog box appears (Figure E-1).

2. Choose Org Plus 3.1, 4.0, 5.0, 6.0 from the “File formats”
pull-down menu.

" Open Chart
File Name: Directories:
t.' J c:\orgplus
bbnarrow.fon [ #| = e\ | #]
bbsmall.fon £= orgplus
opw.exe
opw.hip
opwien.dll
samplel.opw r [] Template
sample2.opw Drives:
tutorl.opw fyes:
tutor2. opw | | l He: |!]
4
File formats:
Org Plus 3.1, 4.0, 5.0, 6.0 *.7) [+
. All Files(*.%)

Org Plus For Windows (*.0PW)
Org Plus Exchange (*.0PX

Plus 3.1, 40,50, 60"
Comma-delimited text [*.TXT)
Tab-delimited text [*. TXT)
Comma-delimited text [PC-8] (*.TXT)
T ab-delimited text [PC-8] (. TXT)

Figure E-1. Opening an Org Plus for DOS file
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Differences between
DOS and Windows
versions

Locate and open the Org Plus for DOS file.

Org Plus for Windows creates a new, untitled chart containing
the information in your Org Plus for DOS file. The new chart
will contain all data, except consolidated amounts, and most
chart formatting options.

To open an Org Plus Advanced version 6.01 or later chart, do the
following:

1.

Choose Open from the File menu.
The Open Chart dialog box appears.

Choose Org Plus Exchange from the “File formats” pull-
down menu.

Locate and open the Org Plus for DOS file.

Org Plus for Windows creates a new, untitled chart containing
all the information in your Org Plus for DOS file.

You can change and save your new Org Plus chart as you can any
other Org Plus for Windows chart. Your original Org Plus for DOS
file is not affected in any way.

There are a few differences between Org Plus for Windows and
Org Plus for DOS.

You can enter much more information into the boxes of your
chart with Org Plus for Windows. See Appendix D, page 211,
in the Org Plus for Windows User’s Manual for details.

Org Plus for Windows gives you much more control over the
appearance of your chart. Any group can have any chart style.

Org Plus for Windows is more sophisticated about the way it
arranges boxes on the page. It can create more compact charts
than Org Plus for DOS.

Version 2.0 supplement 5



u Org Plus for Windows does not support the Tables/Reports
and Amounts capabilities found in Org Plus for DOS.

Saving as Org Plus for  Org Plus for Windows can save charts in a file format that can be
DOS read directly by the following DOS versions of Org Plus and
Org Plus Advanced:

Org Plus version 3.1

Org Plus Advanced version 4.0

Org Plus Advanced version 5.0

Org Plus Advanced version 6.0

Org Plus Advanced version 6.01 and later

Org Plus version 3.1, Org Plus Advanced version 4.0, 5.0, and 6.0
share the same chart file format. Org Plus Advanced version 6.01
and above use the Org Plus Exchange (OPX) chart file format.

To save your Org Plus for Windows chart in a format readable by
Org Plus version 3.1 or Org Plus Advanced version 4.0, 5.0, or 6.0
do the following:

1.  Choose Save As from the File menu.

The Save Chart dialog box appears (Figure E-2).

2.  Choose Org Plus 3.1, 4.0, 5.0, 6.0 from the “File formats”
pull-down menu.

3.  Type a name for your file in the File Name box.

4. Click the OK button.

You can now open your chart with either Org Plus version 3.1 or Org
Plus Advanced version 4.0, 5.0, or 6.0.
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File Name: Directories:
I = | c:\orgplus

Bhnawow ton kd = en ’L
bhamall lon

opw. 0% & oigplus
o hip

opwion ¢8 ||

samplel opw &

samyled opw Drives:

natori opes fyes:

miord opw | ] (=K *

1 [ ]

File formats:

Org Plus 3.1, 4.0. 5.0, 6.0 [~.7) L4

Org Plus For Windows (*.0PW) 1+

" Org = OPX :

Comma-delimited text = TXT]

Tab-delimited text [=.TXT)

Comma-delimited text [PC-8] (=.TXT)

Tab-delimited text [PC-8] [=.TXT)

Windows bitmap (*.BMP)

= Save Chart

Figure E-2. Saving as an Org Plus for DOS file

To save your Org Plus for Windows chart in a format readable by
Org Plus Advanced version 6.01 or later, do the following:

1.

2.

4.

Choose Save As from the File menu.

Choose Org Plus Exchange from the ‘“File formats” pull-
down menu.

Type a name for your file in the File Name box.

Note: file names must have an “OPX” extension.

Click the OK button.

You can now open your chart with any version of Org Plus
Advanced version 6.01 or later.
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Opening Org Plus for
Macintosh files

Opening Text files

To open an Org Plus for Macintosh® chart, you must first save the
chart in Org Plus for Macintosh with the Org Plus for IBM file
format, then transfer the file to your IBM or compatible computer.
You can transfer files on some types of networks. In addition, if
your Macintosh is equipped with the Apple SuperDrive™, you can
use the Apple File Exchange™ utility to transfer Macintosh
documents to 3.5-inch IBM formatted disks. Consult your
Macintosh owner’s manual and your Org Plus for Macintosh User’s
Manual for further instructions.

Org Plus can open a text file saved in a tab- or comma-delimited
ASCII file format. “ASCII” stands for “American Standard Code for
Information Interchange.” There are four standard ASCII file
formats:

ANSI Tab-delimited files
ANSI Comma-delimited files
PC-8 Tab-delimited files
PC-8 Comma-delimited files

ANSI format files are generated from Windows applications, and
PC-8 files are generated from DOS applications. A tab separates
each text value, date, or number in a “Tab-delimited” file. A comma
separates each text value, date, or number in a “Comma-delimited”
file. In addition:

m  Field values such as names and titles must be enclosed within
double quotes (in the ANSI or PC-8 Comma-delimited format
only).

®  Each record — each row — in your text file must have the same
number of fields that are in the same order.

If your data records contain the name of the employee’s manager,
Org Plus can preserve the reporting relationships of the people in
your organization. If your data records do not contain the name of
the employee’s manager, Org Plus creates arbitrary reporting
relationships that you can then change by moving the boxes around.
(See “Moving boxes in your chart,” page 103 of the Org Plus for
Windows User’s Manual).
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For example, the text file shown in the top window of Figure E-3
creates the chart in the lower window. If your text file appears as
shown in Figure E-4, the chart will appear differently.

To open a text file, do the following:

1.

Choose Open from the File menu.
The Open Chart dialog box appears.

Choose “Tab-delimited text” or ‘“Comma-delimited text”
from the “File formats” pull-down menu (located at the
bottom of the Open Chart dialog box) if your ASCII file
was generated from a Windows application.

Choose “Tab-delimited text (PC-8)”’ or “Comma-delimited
text (PC-8)” from the “File formats” pull-down menu
(located at the bottom of the Open Chart dialog box) if
your ASCII file was generated from a DOS application.

Locate and open the text file.

A dialog box appears asking whether the text file contains the
name of each record’s manager.

If the text file does not contain the name of the manager,
click No, and stop here. You do not need to read further.
Org Plus creates a new, untitled chart that you can change and
save as you would any other Org Plus chart.
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With manager data
"Chris Phillips","President & CEO","Board of Directors"
"Lynn Brewer","Chief Financial Officer","Chris Phillips"
"Larry Stevens”,"Vice President”,"Chris Phillips"
"Tina Nomura","COO","Chris Phillips"
"Cathi Fineran","Facilities","Tina Nomura"

Chris Philtips
President & CEO

Lynn Brewer Larry Stevens Tina Nomura
Chief Financial Officer Vice President [dee)
Cathi Fineran
Facitit
3
« >

Figure E-3. Preserving the reporting relationship

Without manager data

"Chris Phillips","President & CEQ"
"Lynn Brewer","Chief Financial Officer"
"Larry Stevens","Vice President"”

"Tina Nomura","COQO"

"Cathi Fineran","Facilities"

Chis Phitips
President & CEO

Lynn Brewer Larry Stevens Tina Nomura Cathi Fineran
Chief Financial Officer Vice President [elole] Facilities

Figure E-4. An arbitrary reporting relationship
If the text file does contain manager data, click Yes.

The Text Import dialog box appears, as shown in Figure E-5.

10 Version 2.0 supplement



= Text Import

Drag data up to match:

Manager's name
Employee's name

President & CEQ
‘Chris Phillips
Board of Directors

..........

Cancel ]

..........

Figure E-5. The Text Import dialog box

The data in the first record of the text file appears in a column
at the lower right. A scroll bar appears on the right side of the
dialog box when all the data does not fit. Scroll down to see
all of the data for the current record if it’s not currently visible.

You can also scroll to the right to see the data for other records
in the text file.

4.  Drag up the manager’s name until it is next to the first
equal sign (see Figure E-6).

5.  Drag up the employee’s name until it is next to the second
equal sign (see Figure E-6).

If your text file has the name separated into parts (first name,

= Chris middle name, last name), the name parts will appear on
A. ' different rows in the Text Import dialog box. Drag all the name
Phillips parts up so that they are stacked up to the right of and below the

equal sign (see figure to left). Make sure you put them in the
right order (first name above middle name, middle name above
last name).
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When steps 4 and 5 are complete, you should have a data value
opposite the two equal signs, as shown in Figure E-6. There
may be some data below the dotted line — ignore it.

Text Import

Drag data up to match:

Manager's name Board of Directors
Employee's name Chris Phillips

President & CEO

Cancel | L 0K

Figure E-6. Matching the data values

If each data record has the same data in the same order, the
match up will be correct for all records in the text file. You
can check this by clicking the left and right arrows of the

horizontal scroll bar to view the other data records in the text
file.

Click the OK button.

Org Plus creates a new, untitled chart that you can change and
save as you would any other Org Plus chart.

12
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Saving as a Text file

Saving as a Windows
bitmap

To save an Org Plus chart as a text file, do the following:

1.

2.

3.

4.

Choose Save As from the File menu.

Choose “Tab-delimited text” or “Comma-delimited text”
from the “File formats” pull-down menu for a Windows
application.

Choose “Tab-delimited text (PC-8)” or “Comma-delimited
text (PC-8)’ from the “File formats” pull-down menu for a
DOS application.

Type a name for your text file in the File Name box.

Click the OK button.

Org Plus creates a text file containing all the data that you have typed
for each box in the chart, including the name of the manager. Many
applications can read files with data saved in all four text formats.

A bitmap is a standard Windows graphics image format. Most
Windows applications open or import bitmap files.

To save an Org Plus chart as a bitmap file, do the following:

1.

2.

3.

4.

Choose Save As from the File menu.

Choose “Windows bitmap” from the “File formats” pull-
down menu.

Type a name for your bitmap file in the File Name box.

Click the OK button.

Org Plus saves a complete image of the chart in the bitmap file with
the specified name.
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Saving as a Windows A metafile is a standard Windows graphics image format. It requires
metafile much less disk space than the Windows bitmap format. Many
applications open or import metafiles.
To save an Org Plus chart as a metafile, do the following:

1. Choose Save As from the File menu.

2. Choose “Windows metafile” from the “File formats” pull-
down menu.

3.  Type a name for your file in the File Name box.
4.  Click the OK button.

| Org Plus saves a complete image of the chart as a metafile with the
| specified name.

Saving as a TIFF file TIFF (Tagged Information File Format) is a graphics image format
used by many DOS, Windows, and Macintosh applications. Use
TIFF if you want to transfer an image of your chart to an application
on a Macintosh, DOS, or Windows application that does not support
metafiles or bitmaps.

| To save an Org Plus chart as a TIFF file, do the following:

1.  Choose Save As from the File menu.

2. Choose “TIFF” from the “File formats” pull-down menu.
3.  Type a name for your file in the File Name box.

4.  Click the OK button.

Org Plus saves a complete image of the chart as a TIFF file with the
specified name.
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Saving as a
PC Paintbrush file

Copying and pasting
between applications

PC Paintbrush is a graphics image format used by PC Paintbrush
from ZSoft® Corporation.

To save an Org Plus chart as a PC Paintbrush (PCX) file, do the
following:

1.  Choose Save As from the File menu.
2.  Choose “PCX” from the “File formats” pull-down menu.

3.  Type a name for your file in the File Name box.
4.  Click the OK button.

Org Plus saves a complete image of the chart as a PC Paintbrush
(PCX) file with the specified name.

This section tells you how to copy and paste information between
Org Plus and other Windows applications.

You can copy text from most Windows applications to the Clipboard
and then paste it into your chart wherever you enter an insertion
point (the blinking vertical bar).

You can also copy pictures from many Windows applications
directly to the Clipboard and paste them directly into your chart. See
“Placing pictures into your chart,” page 153 of the Org Plus for
Windows User’s Manual, for details.

You can also copy and paste a rectangular portion of your chart to
the Clipboard and then paste it into an application that accepts
Bitmap and Picture (metafile) clipboard formats. These are standard
formats for graphics images. To copy and paste a portion of your
chart, do the following:

1.  Choose the level of magnification you want from the Chart
menu.
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Object Linking and
Embedding

Note: what you see in the chart window is exactly what you
can copy to the Clipboard.

To copy an image of the entire chart, choose Size to Window
from the Chart menu.

2.  Press and hold the Ctrl key while you drag a rectangle
around the portion of your chart you want to copy to
another application.

When you release the mouse button, Org Plus places two
representations of the rectangular area you defined on the
Clipboard. One is in bitmap format and the other is a metafile
format.

3. Switch to the Windows application where you want to
paste the chart image.

4.  Click or position the insertion point where you want to
paste the graphic image.

5. Choose Paste from the Edit menu.

The other application will paste the appropriate format (bitmap or
metafile) of the chart image automatically.

Org Plus supports Object Linking and Embedding (OLE), a feature
that lets you create and edit a chart in Org Plus and automatically
transfer it to another application. Other applications that support
OLE include word processors and desktop presentation programs.
Once your chart is in the Windows OLE client application, you can
open Org Plus and edit it from within that application.

Org Plus functions as an OLE server. You can use it with any
application that functions as an OLE client. An OLE server
application such as Org Plus creates the chart; an OLE client
application, such as Microsoft Word® 2.0, contains the chart.

16
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Object Linking vs.
Object Embedding

Embedding a chart

Embedding from within
the client application

This section tells you how to transfer an Org Plus chart, or portion of
a chart, to another client application. First, however, you should
understand the difference between embedded charts and linked
charts.

An object is a chart or a portion of a chart that you want to place in
another Windows application.

You can embed an object in an OLE client application document, or
you can link an object to a client document. When you embed an
object in a OLE client document, you place a copy of the original
object in the client document. It is then completely separate from the
original chart. You can edit the embedded object independently
from the original chart.

When you link an object to a client document, the object appears in
the client document, but it still resides in the original Org Plus
document. The client document is automatically updated when you
make a change to the object in the original Org Plus document.

For a more thorough description of Object Linking and Embedding,
see Chapter 13 or the index of your Microsoft Windows 3.1 User’s
Guide.

There are two ways to embed a chart in a client application’s
document. The first way is to start in the client document where you
want the embedded chart to appear. The second way is to start from
within Org Plus.

To embed a chart, do the following:

1.  Open the application and the document into which you
want to embed the chart.
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Move the insertion point to the place you want the Org
Plus chart inserted, or make whatever preparations
required by the application.

Look in the index of the application’s manual under
“embedding objects” for specific instructions.

Choose Insert Object from the application’s Edit menu.

If you can’t find the Insert Object command, see if there is an
Object command in an Insert menu. If you can’t find either
command, your application probably doesn’t support this
method of embedding objects.

The application should display a dialog box, such as the one
shown in Figure E-7.

Object Type:
Microsoft Excel Macrosheet |+
Microzoft Excel Worksheet |
Microszoft Graph

MS WordArt
Orq Plus Chart
Package
Paintbrush Picture
Sound

Figure E-7. Inserting an object

The dialog box lists all the applications on your computer that
support OLE.

Select Org Plus Chart.
Click the OK button.
This opens Org Plus.

Create a chart.

18
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Embedding from
Org Plus

Choose Update from the Org Plus File menu.
This places the chart into the client document.
Choose Exit from the Org Plus File menu.

You are now back in the client application with the chart you
just created.

To embed a chart starting from Org Plus, do the following:

1.

2.

Open Org Plus.

Create a chart or open an existing file containing the chart
you want to embed.

If you want to save the chart, choose Save from the File
menu.

Select the portion of the chart you want to embed.

To select the entire chart, choose All from the Select submenu,
located in the Edit menu. Chart titles and background objects
are selected by default. If you do not want to include the
chart’s title or background objects, you must first deselect
these options at the Select Special Options dialog box. To
change your options, choose Select Special Options from the
Edit menu.

If you want to embed a branch of the chart, select the branch.
Chart titles, background objects (including connecting lines
made with the Connecting Line tool) are never selected when
branches are embedded.

Choose Copy from the Edit menu.
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Open the application and the document into which you
want to embed the chart.

Move the insertion point to the place you want the chart
inserted, or make whatever preparations are required by
the client application.

Look in the index of the application’s manual under
“embedding objects” for specific instructions.

Choose Paste from the application’s Edit menu.
The chart will appear in the client document.

A change made to the original chart will not appear in the chart that
is embedded into the client document.

Editing an embedded To edit an embedded chart from inside the client document, do the
chart following:

1.  Open the application and the document containing the
embedded chart.

2.  Double-click the embedded chart.

Org Plus opens with a “live” copy of the embedded chart.

3.  Edit the chart as needed.

4.  Choose Update <file name> from the Org Plus File menu
where < file name> is the file name of your client
document.

The chart in the client document is updated to reflect your
edits.

5. Choose Exit from the Org Plus File menu.

Org Plus closes.
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Linking a chart

When you create a link to an Org Plus chart, an image of the chart is
displayed in the client document. There is a link between the
original Org Plus document and the client document.

You can link an entire chart or a branch of a chart. You can do so
only from a saved chart. If you open Org Plus and create a chart,
you must save it before linking it to the other application.

When you make changes to the original Org Plus chart, the changes
appear in every client document that contains a link to the chart.

To link a chart to a client document, do the following:

1.

2.

Open Org Plus.

Create a chart or open an existing file that contains the
chart you want to link.

Save the chart.
Select the portion of the chart you want to link.

To select the entire chart, choose All from the Select submenu,
located in the Edit menu. Chart titles and background objects
are selected by default. If you do not want to include the
chart’s title or background objects, you must first deselect
these options at the Select Special Options dialog box. To
change options, choose Select Special Options from the Edit
menu.

If you want to link a branch of the chart, select the branch.
Connecting lines made with the Connecting Line tool are
included in the linked branch if both ends of the connecting
line are to boxes in the branch and the lines are within the
rectangular area formed by the top and bottom of your branch.
If you want to link the branch without any background objects,
you must first deselect this option in the Select Special Options
dialog box. Chart titles are never selected when branches are
linked.
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Using the Paste Special
command

5. Choose Copy from the Org Plus Edit menu.

6.  Open the application and the document into which you
want to link the chart.

7.  Move the insertion point to the place you want the chart
inserted, or make whatever preparations are required by
the client application.

Look in the index of the client application’s manual under
“linking objects” for specific instructions.

8. Choose Paste Link from the Edit menu.

If there is no Paste Link command, choose Paste Special. See
“Using the Paste Special command,” below, for more
information.

You now have the original Org Plus chart and a link to that
chart in the client document.

Some client applications have a Paste Special command rather than a
Paste Link command. Some client applications may have both. The
Paste Special command gives you more control over the paste
operation than the Paste Link command.

When you choose the Paste Special command, the client application
will display a dialog box like the one shown in Figure E-8.

= Paste Special

Source: Drg Plus Chart
SAMPLE1.0PW -1

Org Plus Chart Object

Picture
Bitmap

Figure E-8. Using the Paste Special command

22
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Editing a linked chart

The dialog box lists the different objects on the Clipboard. You are
free to choose any of these objects. If you select an object in the list
and the Paste button becomes selectable, then the object can be
embedded. If you select an object in the list and the Paste Link
button becomes selectable, then you can link the object.

Select the type of object you want to embed or link, then click the

appropriate button.

You edit a linked chart the same way you edit an embedded chart.
The only difference is that any changes you make to a linked chart
appear in all the client documents containing that chart, in addition to
the original Org Plus document containing the chart.

To edit a linked drawing, do the following:

1.  Open the application and the document containing the
linked chart.

2.  Double-click the linked chart.

Org Plus opens the chart with the original linked chart.
3.  Edit the chart as needed.
4.  Choose Save from the Org Plus File menu.
5.  Choose Exit from the Org Plus File menu.

The open chart is closed and you exit from Org Plus.
The linked chart in the client document is updated to reflect your
edits if the Update option is set to Automatic. If the Update option is
set to Manual, you must update the link by using the Links
command. (This is avalable from the File or Edit menu of most

client applications). See “Maintaining links,” page 25, for more
information.
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Select Special Options

The Select Special Options command under the Edit menu lets you
select whether your chart is embedded or linked with background
objects or titles.

To change your special options:

1.

Choose Select Special Options from the Edit menu.
The Select Special Options dialog box appears.
Click the check box for the attribute you want to change.

The default setting is for both background objects and titles to
always be included when the entire chart is selected. To
embed or link your entire chart without a chart title, deselect
the Paste chart titles along with boxes check box. To embed or
link your chart without background objects, deselect the Paste
background objects along with boxes check box.

Chart titles are not included if a branch is selected for linking
or embedding even if the Paste chart titles along with boxes
check box is checked.

Background objects are not included with an embedded branch
even if the Paste background objects along with boxes check
box is checked.

Background objects are included with a linked branch if the
Paste background objects along with boxes check box is
checked. The background object must be within the
rectangular area formed by the top and bottom of your branch.

Click the OK button.

24
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Maintaining links

OPWMainClass CADRGPLUSATU... 24 Automatic B

When you link a chart to a client document, it is possible for the link
to later be broken. You will know the link is broken if you double-
click the chart in the client document and see a message saying that
the linked chart cannot be found. This can happen if the linked chart
has been renamed, deleted, or moved.

&

Update: @ Automatic ) Manual [ Locked

| Open Source | I Update Nlll I LCancel Link—l [ Change Link...J

Figure E-9. Using the Links command

Many applications, such as Microsoft Word, have a Links command
found under either the File or Edit menu. When you choose the
Links command, the client application will display a dialog box like
the one shown in Figure E-9. This command gives you information
on the objects that are linked to your document and allows you to
make changes to the objects’ status.

The Links box within the Links dialog box displays four columns of
information on each object that is linked to your document. The first
column lists the Windows registered name for the object. The
second lists the source (location) of the object. The third lists the
type of information that is linked, and the fourth column lists the
update option being used.

For example, the Figure E-9 Links box shows OPWMainClass in the
first column, the Windows registered name for Org Plus. The second
column shows that the object linked is located in the C:\ORGPLUS
directory. The third column shows the type of information, *“24.”
This is an internal number used by Org Plus to point to the top of the
branch selected. The number will vary depending on the branch you
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OLE exercise

select. Org Plus will display a “-1” in the type of information linked
column when the entire chart is selected. The fourth column shows
that the Automatic update option has been selected.

To change your update option, click either the Automatic or Manual
selection in the Update options line. If you select Automatic,
whenever a change is made in Org Plus, that change is shown
immediately in your client document. You don’t have to request
updates, and you always have the most recent information. If you
select Manual, you must click the Update Now button before any
changes to your Org Plus chart are shown in your client document.
This option gives you more control over your client document.

When a link is broken, you can either delete the link and start over,
or try to fix the link. For detailed instructions, see Chapter 13,
“Integrating Your Windows Applications,” in your Microsoft
Windows 3.1 User’s Guide, the section entitled “Maintaining Links.”

This section provides an exercise to help you understand how
compound documents are created between Org Plus and Microsoft
Word 2.0.

Creating a linked chart This example shows how to create a chart in Org Plus, then link the
in Microsoft Word 2.0 chart as an object into a Microsoft Word 2.0 file. (See “Linking a
chart,” page 21, for more information).
1.  Open Org Plus.
2.  Create a chart or open an Org Plus file that contains the
chart you want to link.
3.  Save the chart if you created a new one.
4.  Select the portion of the chart you want to link.
5. Choose Copy from the Org Plus Edit menu.
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10.

11.

12.

Start Microsoft Word 2.0 by double-clicking its program
icon in the Program Manager window.

Type some text in Microsoft Word 2.0.

You should also press Enter twice to leave some space
between your text and the chart you will be inserting.

Choose Paste Special from the Microsoft Word 2.0 Edit
menu.

When you choose the Paste Special command, Microsoft Word
2.0 will display the dialog box like the one shown in Figure E-
8 on page 22.

The Paste Link button should be selectable only for the Picture
and Bitmap options on the Data Type list.

Choose Picture from the Data Type list.
Click the Paste Link button.

The chart you created should now appear below the text you
typed.

Choose Save from the Microsoft Word 2.0 File menu and
type any name in the File Name box of the Save dialog.

Choose Exit from the Microsoft Word 2.0 File menu.

Any changes you make to the chart in Org Plus will be automatically
reflected in your linked chart in the Microsoft Word 2.0 document
when you open it. (See “Maintaining links,” page 25, for more
information.)
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Creating an embedded

This example shows how to create a chart in Org Plus, then embed

chart in the chart as an object into a Microsoft Word 2.0 file.
Microsoft Word 2.0
1.  Open Org Plus.
2.  Create a chart or open an Org Plus file that contains the
chart you want to embed.
3. Select the portion of the chart you want to embed.
4.  Choose Copy from the Org Plus Edit menu.
S.  Start Microsoft Word 2.0 by double clicking its program
icon in the Program Manager window.
6.  Type some text into Microsoft Word 2.0.
You should also press Enter twice to leave some space
between your text and the chart you will be inserting.
7.  Choose Paste Special from the Microsoft Word 2.0 Edit
menu.
When you choose the Paste Special command, Microsoft Word
will display the dialog box like the one shown in Figure E-8,
page 22.
8.  Choose Org Plus Chart Object from the Data Type list.
9.  Click the Paste button.
The chart you created should now appear below the text you
typed.
10. Choose Save from the Microsoft Word 2.0 File menu and
type any name in the File Name box of the Save dialog.
11. Choose Exit from the Microsoft Word 2.0 File menu.
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Editing an embedded or
linked chart

Any changes you make to the chart in Org Plus will not be reflected
in the embedded chart in the Microsoft Word 2.0 file when you open
it.

To edit either a linked or an embedded chart from within Microsoft
Word 2.0, do the following:

1.  Start Microsoft Word 2.0 by double-clicking its program
icon in the Program Manager window.

2.  Choose Open under the Microsoft Word 2.0 File menu and
type the name of the file you saved under the section
“Creating a linked chart in Microsoft Word 2.0’ or
“Creating an embedded chart in Microsoft Word 2.0.”

Microsoft Word 2.0 will display either the linked or embedded
document you saved in the previous sections.

3. Double-click the chart.

If you linked your chart, Org Plus opens the original chart. If
you embedded your chart, Org Plus opens a copy of the chart.

4.  Edit the chart as needed.

5.  Choose Save from the Org Plus File menu if it is a linked
chart. Choose Update <file name> from the Org Plus File
menu if it is an embedded chart.

6.  Choose Exit from the Org Plus File menu.

The open chart is closed and you exit from Org Plus and return
to Microsoft Word 2.0.

7. Choose Save from the Microsoft Word 2.0 File menu.

8. Choose Exit from the Microsoft Word 2.0 File menu.
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Common problems

Here are some common problems you may have using Org Plus with
other applications and the possible solutions.

Problem...

This could be the reason...

Modified a linked chart but it
is not updated in the client
application.

Paste Link is not selectable.

Double-clicking on a chart
object in the client application
and nothing happens.

Chart fonts look different in

the client application than in
Org Plus.

Your update option is set to
Manual. Use the Links
command to change your
update option to Automatic.

You have embedded the
chart or only used the Paste
command. Use the Links
command to check if you
linked the chart.

You did not save your chart.

You did not copy your chart
to the Clipboard. Select
your chart in Org Plus and
use the Copy command
under the Edit menu.

Your application does not
support client OLE.

You specified a very small
area in which to place your
chart in your client
document. At high
magnifications, fonts may
look different. Scale or
resize the object to see if this
problem is corrected.
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Problem...

This could be the reason...

Client document or Org Plus
becomes unstable. For
example, you cannot bring
down the menu or save
information.

Cannot import a TIFF image
of the chart, or the quality of
the image is poor.

Double-clicking on the chart
object in the client document
opens an application other
than Org Plus.

You are low on System
Resources. Choose About
Program Manager from the
Help menu in the Program
Manager window. Your
System Resources must be
above 40%. If you are
below 40%, close other
applications to increase your
System Resources. Check
your Windows manual to
optimize your memory
usage.

Your application does not
support a version of TIFF
that is compatible with Org
Plus. You should try
another graphics file format
such as WMF, BMP, or
PCX.

You did not select the
correct data type (for
example, Org Chart Object,
Picture, Bitmap, etc..) when
you embedded or linked
your chart. Refer to your
client document to see the
data type you should select.
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Print Setup

Other features and hints

This section discusses other new features available and how to
trouble-shoot your system. The features discussed replace
capabilities documented in the Org Plus for Windows User’s
Manual.

The Printer Setup command under the File menu has been renamed
Print Setup. The dialog box shown in Figure E-10 will appear when
the command is selected.

The Page Setup command under the File menu has been removed.
All settings found in the Page Setup dialog box in Org Plus for
Windows version 1.0, except for “Graphics Resolution,” can now be
found in the Print Setup command under the File menu. The
“Graphics Resolution” setting can now be found in the Print
command.

[currently HP LaserJet Series Il on LPT1:)

O Specific Printer: Options...

EP LaserJet Series Il on LPT1: T-‘Tl Help

i

I~ Orientation Paper
@ Portrait Size: ILellet 81/2x11in _I?]

O Landscape Source: Mper Tray IgJ

Figure E-10. The Print Setup dialog box for the HP LaserJet IT

In the Print Setup dialog box, you can select the default printer or a
specific printer. Your chart will be saved with the selection you
make. If you select Specific Printer, the printer settings you set in
Windows will not affect your chart. For example, if you selected
Specific Printer with an HP LaserJet II and later changed your printer
settings to HP DeskJet, your chart would still reflect the printer
specifications for an HP LaserJet II.
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Printing your chart

The Print Chart dialog box shown in the Org Plus for Windows
User’s Manual has been replaced with the Print dialog box.

The dialog box shown in Figure E-11 will be displayed when the
Print command is selected.

Printer: HP Laserlet Series Il on LPT1:

Cancel

™ Print Range
o
& Selected branch
(> Pages
Brom [ ] To: ]

Pint Qualty: [ETECMN:)  Covies: [ ]

[ Print Color  [] Collate Copies

Figure E-11. Print Chart dialog box

All instructions described in “Printing your chart,” page 158 in the
Org Plus for Windows User’s Manual, are applicable to the new
dialog box.

The “Graphics Resolution” setting found in the Page Setup dialog
box in Org Plus for Windows version 1.0 has been replaced by the
Print Quality setting in the Print dialog box.

Clicking the Setup button will bring up the Print Setup dialog box
described on page 32.
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Placing pictures into
your chart

Font command

In addition to Windows bitmap (BMP), you can also import
Windows metafile (WMF), Tagged Information File Format (TIFF),
and PC Paintbrush (PCX) graphics files into the boxes or the
background of a chart. See “Placing pictures into your chart,”

page 153 in the Org Plus for Windows User’s Manual, for more
information.

To choose the type of graphics file you are importing, select from the
“File formats” pull-down menu in the Import Picture dialog box.

The Font command under the Text menu now displays the dialog
box shown in Figure E-12. The dialog box allows you to select your
font, font style, and font size.

El TimesNewRomanP$S
T Wingdings
Za|

A:BbYyZz

This is a TrueType font. This same font will be
used on both your printer and your screen.

Figure E-12. Font command dialog box

You also have the option to select your font size through the Size
command and your font style through the Style command as
documented in the Org Plus User’s Manual. Changes to font size
and font style made through the Font command will be reflected in
the Size and Style commands.
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System
trouble-shooting for
Microsoft Windows

A clean boot is often necessary to ascertain whether you are
experiencing problems because of your system environment.

To perform a clean boot, the Windows operating environment
requires that you leave your system configuration somewhat intact.

You must edit your WIN.INI, CONFIG.SYS and AUTOEXEC.BAT
files in order to prepare your system for the clean boot. The editing
steps outlined assume that you do not have a TSR (Terminate Stay
Resident) program that your system requires in order to function
properly. Examples of such TSRs are disk doubling programs or the
drivers that enable you to connect to a network. You will need to
identify and not change these lines in your CONFIG.SYS and
AUTOEXEC.BAT files. Refer to documentation provided by your
TSR program.

To edit your files:

1.  While running Windows, bring up the Program Manager.

2.  Select Run from the File menu.

3.  Type SYSEDIT in the Command Line box and click OK.
This will bring up the System Edit program, along with your
SYSTEM.INI, CONFIG.SYS, AUTOEXEC.BAT, and
WINL.INI files. You do not need to change your SYSTEM.INI
file.

4. Type REM at the beginning of each line in the
AUTOEXEC.BAT file.

Figure E-13 shows a sample AUTOEXEC.BAT file that has
been edited for a clean boot.
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REM PATH CAWINWORD;C:\PR2US;C:\ALDUS;CMLDUS\PR2U,

CMAUTOEXEC.BAT

REM prompt SpSg

REM SET GMKW5=D:\GMKW
REM smartdrv 1024 1024

REM mouse ser 1
REM subst g: c:
REM SET LIB=C:\C600\LIB

Figure E-13. Sample AUTOEXEC.BAT file

Type REM at the beginning of each line of the
CONFIG.SYS file except for the lines which start with the
following entries:

files=...

buffers=...

stacks=...
device=<path>himem.sys

Figure E-14 shows a sample CONFIG.SYS file that has been
edited for a clean boot.

CACONFIG.5YS

device=c:\dosthimem.sys

REM device=c:\tditdh386.sys
REM shell=command.com fe:3072 {p
REM lastdrive=M

Figure E-14. Sample CONFIG.SYS file

Type REM at the beginning of each line in the WIN.INI file
that starts with:

run=
load=
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Figure E-15 shows a sample WIN.INI file that has been edited
for a clean boot.

| D:AWINDOWSIWIN.INI
[windows]
spooler=yes

Beep=yes
NullPort=None
BorderWidth=3

Figure E-15. Sample WIN.INI file

7.  Save the changes and quit Windows.

8.  Restart your computer. When you load Windows, hold
down the Shift key. This will prevent any programs in the
Startup Program Group from loading.

9.  Start Org Plus and make sure it functions properly.

If your program functions properly after you do a clean boot, then
you know that something in your AUTOEXEC.BAT, CONFIG.SYS,
or WINL.INI file is causing the problem.

Use SYSEDIT to place a REM in front of the lines you suspect may
be causing the problem, or contact the manufacturer of the product in
question. If the clean boot did not solve your problem, there is a
good chance that the problem you are experiencing is being caused
by your computer hardware or an error in the program itself. Please
call Banner Blue’s Technical Support if this is the case.
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Linking
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